Pobieranie prezentacji. Proszę czekać

Pobieranie prezentacji. Proszę czekać

Model kolejkowy Symulacja zdarzeniowa i procesowa.

Podobne prezentacje


Prezentacja na temat: "Model kolejkowy Symulacja zdarzeniowa i procesowa."— Zapis prezentacji:

1 Model kolejkowy Symulacja zdarzeniowa i procesowa

2 Zdarzenia Zdarzenie to każda zmiana w stanie systemu. Zdarzenie ma miejsce w danej chwili. Nie definiuje się czasu trwania zdarzenia STOP Pobierz zdarzenie z kalendarza Uaktualnij czas CzasAkt

3 Założenia FIFO – reguła obsługi kolejki Rozkłady losowe: 1.Przybycia klientów modelowane rozkładem Poissona λ = średnie tempo przybywania klientów wyrażone liczbą klientów pojawiających się w jednostce czasu (1/ λ = średni czas pomiędzy kolejnymi przybyciami) 2. Obsługa klientów modelowana rozkładem wykładniczym μ = średni czas obsługi, wyrażone liczbą klientów obsłużonych w jednostce czasu (1/ μ = średni czas obsługi)

4 Myjnia samochodowa zW myjni samochodowej jest jedno stanowisko. zKlienci przybywają losowo w godzinach 11:00 do 13:00 w tempie 15 samochodów na godzinę (lub inaczej – 1 samochód co 4 minuty; 15 aut/godz=15 aut/60 min = 1 auto/4 min) zJedno mycie to około 3 minuty (1 auto/3 min = 20 aut/ 60 min = 20 aut/1 godz) zWłaściciel nie rozumie, czemu czasami tworzą się kolejki. Chciałby poznać: czas oczekiwania klientów, liczbę oczekujących, czas pracy i bezczynności urządzenia zSymulację prowadzimy dla 120 minut (2 godziny) pracy myjni

5 Myjnia samochodowa - model zdarzeniowy. Wiersz 1 L2=D12M2=-H6*LN(LOS()) N2=1O2=0 P2=D15Q2=M2 R2=M2+(-H6*LN(LOS())) S2=M2+(-$H$7*LN(LOS()))

6 Myjnia samochodowa - model zdarzeniowy. Wiersz 2 i kolejne L3=JEŻELI(R2<=S2;$D$12;$D$13)M3=MIN(R2;S2) N3=JEŻELI(L3=$D$13;N2-1;N2+1)O3=MAX(N3-1;0) P3=JEŻELI(N3=0;$D$14;$D$15)Q3=JEŻELI(P2=$D$14;M3-M2;0) R3=JEŻELI(L3=$D$12;M3+(-$H$6*LN(LOS()));R2) S3=JEŻELI(ORAZ(L3=$D$13;N3>0);M3+(-$H$7*LN(LOS())); JEŻELI(ORAZ(L3=$D$13;N3=0);99999; JEŻELI(ORAZ(L3=$D$12;P2=$D$14);M3+(-$H$7*LN(LOS()));S2)))

7 Myjnia samochodowa - model zdarzeniowy Czas następnego zdarzenia Odjazd: JEŻELI(L3=Odjazd i Liczba klientów>0) to =M3+(-$H$7*LN(LOS())); (1) JEŻELI(L3=Odjazd i Liczba klientów=0) to =99999; (2) JEŻELI(L3=Przybycie i Stanowisko=Wolne to =M3+(-$H$7*LN(LOS())) (3) =S2(4) STOP Pobierz zdarzenie z kalendarza Uaktualnij czas CzasAkt

8 Myjnia samochodowa – kolumny ze statystykami T2=Q2; U2=Q2/M2*100; V2=0; W2=V2/M2 T3=T2+Q3; U3=T3/M3*100 V3=O2*(M3-M2)+V2 W3=V3/M3

9 Myjnia samochodowa – wyniki Zadana wartość czasu symulacji E24=PODAJ.POZYCJĘ(D23;M2:M101;1) F27=WYSZUKAJ.PIONOWO($E$24;$K$2:$W$101;13) F29=WYSZUKAJ.PIONOWO($E$24;$K$2:$W$101;11) TABELA

10 Myjnia samochodowa – wyniki zNależy: y wyznaczyć statystyki końcowe y zaprojektować wykres: (1)długości kolejki z 1 powtórzenia (2)Średniej długości kolejki z 1 powtórzenia (3)Średniej długości kolejki ze 100 powtórzeń


Pobierz ppt "Model kolejkowy Symulacja zdarzeniowa i procesowa."

Podobne prezentacje


Reklamy Google