Pobieranie prezentacji. Proszę czekać

Pobieranie prezentacji. Proszę czekać

 Formuła to wyrażenie algebraiczne (wzór) określające jakie operacje ma wykonać program na danych. Może ona zawierać liczby, łańcuchy znaków, funkcje,

Podobne prezentacje


Prezentacja na temat: " Formuła to wyrażenie algebraiczne (wzór) określające jakie operacje ma wykonać program na danych. Może ona zawierać liczby, łańcuchy znaków, funkcje,"— Zapis prezentacji:

1  Formuła to wyrażenie algebraiczne (wzór) określające jakie operacje ma wykonać program na danych. Może ona zawierać liczby, łańcuchy znaków, funkcje, operatory arytmetyczne i adresy komórek. Działanie (wzór) w komórce arkusza musimy zapisywać zaczynając od znaku równości „=”, (np. =A1+B1) – formuła na dodawanie liczb z dwóch komórek arkusza. Formuły w arkuszu

2 Operacja arytmetyczna Operator Dodawanie + Odejmowanie ─ Mnożenie * Dzielenie / Potęgowanie ^ UWAGA!!!  W działaniach z nawiasami stosujemy tylko nawiasy „okrągłe”.  np. działanie zapiszemy w arkuszu tak: =((2*3^2)-5)/9 Podstawowe operatory arytmetyczne w arkuszu

3 Podstawowe operatory porównania w arkuszu Operator porównania ZnaczeniePrzykład = znak równościRówny =A1=B1 > znak większy niżWiększy niż =A1>B1 < znak mniejszy niżMniejszy niż =A1= znak większy niż lub równy Większy niż lub równy =A1>=B1 <= znak mniejszy niż lub równy Mniejszy niż lub równy =A1<=B1 <> znak nie równyRóżny =A1<>B1 Możesz porównać dwie wartości za pomocą następujących operatorów. Gdy dwie wartości są porównywane za pomocą tych operatorów, to wynik jest wartością logiczną, PRAWDA lub FAŁSZ.

4 1. ( )Działania w nawiasach 2. :,dwukropek, przecinek, pojedyncza spacja 3. - Negacja 4. % Procent 5. ^Potęgowanie 6. * i /Mnożenie i dzielenie 7. + i - Dodawanie i odejmowanie 8. & Łączy dwa ciągi tekstu (wiązanie) 9. = ; Porównanie =Porównanie <>Porównanie Kolejność wykonywania operacji w formułach Jeśli w jednej formule zostanie umieszczonych wiele operatorów, program Microsoft Excel wykonuje te operacje w kolejności przedstawionej w poniższej tablicy. Jeśli formuła zawiera operatory o takim samym pierwszeństwie - na przykład, jeśli formuła zawiera operator mnożenia i dzielenia - program Microsoft Excel oblicza operatory od lewej strony do prawej. Aby zmienić kolejność obliczania, część formuły, która ma być obliczona w pierwszej kolejności należy zamknąć w nawiasie.

5 Operator tekstowy - łączenia tekstu & Operatora & należy używać do łączenia lub składania jednego lub kilku ciągów tekstowych w celu utworzenia pojedynczego fragmentu tekstu Operator ZnaczeniePrzykład &Łączy lub wiąże dwie wartości w celu utworzenia jednej ciągłej wartości tekstowej "North" & "wind" daje w wyniku "Northwind" Odwołanie do komórki tego samego arkusza tworzymy następująco: =adres komórki np. =A1, =B6 Odwołanie do komórki innego arkusza tworzymy następująco: =nazwa arkusza!adres komórki np. =Arkusz1!A1, =Arkusz2!D10

6 ##### wskazuje, że liczba wprowadzona do komórki jest zbyt szeroka, aby mogła być wyświetlona w komórce. #DZIEL/0! występuje, gdy w formule była wykonana próba dzielenia przez 0 (zero). #NAZWA? ma miejsce, gdy program nie rozpoznaje tekstu w formule (np. pomyłka w nazwie funkcji). #LICZBA! pojawia się w przypadku problemu z liczbą w formule lub w funkcji (np. nie można obliczyć wartości logarytmu liczby ujemnej lub pierwiastka kwadratowego z liczby ujemnej). #ADR! jest widoczny, gdy odwołanie do komórki jest nieprawidłowe. #ARG! występuje, gdy w formule zastosowano nieprawidłowy typ argumentu (np. do formuły wprowadzono tekst zamiast liczby). Gdy popełnimy błąd

7 Często zachodzi potrzeba odwoływania się przy kopiowaniu do adresu konkretnej komórki, w której zapisana jest jakaś ważna dla obliczeń liczba (stała wartość). Wówczas musimy zastosować tzw. adresowanie bezwzględne, wskazujące jednoznacznie na zawartość konkretnej komórki, którą chcemy kopiować do innych formuł. Wymaga to „umocowania” komórki za pomocą znaku $ umieszczonego przed numerem wiersza i kolumny, np. $D$3 UWAGA Przy wpisywaniu formuły można łatwo dodawać symbole $ do komórki, która ma mieć adres bezwzględny. Wystarczy po wpisaniu adresu komórki nacisnąć klawisz funkcyjny F4. Symbole $ zostaną wstawione automatycznie przed etykietą kolumny i wiersza) Adresowanie względne, bezwzględne i mieszane komórek

8 Arkusz kalkulacyjny jest wyposażony w zestaw wielu funkcji arytmetycznych, trygonometrycznych, logicznych i innych, które można wykorzystywać do rozwiązywania różnorodnych zadań. Przykłady funkcji: =ŚREDNIA(x;y) =SUMA(x;y) =PIERWIASTEK(x) =MAX(F2:Z34) =MIN(C3:S14) Funkcja w arkuszu jest wyrażeniem, którego wartość zależy od argumentu funkcji. Argument funkcji umieszczony jest zawsze w nawiasach okrągłych. Argumenty są oddzielane średnikiem ; Funkcje w arkuszu

9 Zakres komórek określa pewien prostokątny obszar arkusza obejmujący blok komórek, które przylegają do siebie. Definiujemy go podając adres dwóch narożnych komórek - lewej górnej oraz prawej dolnej. Adresy te muszą być rozdzielone dwukropkiem: np. A1:C5 =ŚREDNIA(B2:D5) =SUMA(B7:J7) =MAX(F2:Z34) =MIN(C3:S14) Zakres komórek UWAGA znak dwukropka (:) określa zakres ciągły „od do”, czyli zapis =SUMA(G4:G10) oznacza: sumowanie wartości z komórek G4, G5, G6, G7, G8, G9, G10 znak średnika (;) określa zakres nieciągły „i”, czyli zapis =SUMA(G4;G10) oznacza: sumowanie wartości tylko z dwóch komórek G4 i G10

10 Wstawianie funkcje do arkusza Excel wyposażony jest w bibliotekę standardowych nazw funkcji, które zostały pogrupowane zależnie od charakteru zastosowań. Funkcje wywołujemy: - z paska menu Wstaw | Funkcja... - przez ikonę na pasku narzędziowym - klikając na znak = przy pasku formuły i wywołujemy funkcję przez pole nazwy:

11 Funkcja JEŻELI Pozwala na podejmowanie decyzji w arkuszu kalkulacyjnym. Ogólnie można ją przedstawić w postaci poniższego szablonu: =JEŻELI(warunek;wartość1_jeśli_prawda;wartość2_jeśli_fałsz) AB 1 Liczba 2 20 =JEŻELI(A2>0;"Liczba dodatnia";"Liczba ujemna") Funkcja logiczna JEŻELI


Pobierz ppt " Formuła to wyrażenie algebraiczne (wzór) określające jakie operacje ma wykonać program na danych. Może ona zawierać liczby, łańcuchy znaków, funkcje,"

Podobne prezentacje


Reklamy Google