Pobieranie prezentacji. Proszę czekać

Pobieranie prezentacji. Proszę czekać

LOGO KOMENIUSZ Temat: PROCEDURY Z PARAMETRAMI W LOGO KOMENIUSZ.

Podobne prezentacje


Prezentacja na temat: "LOGO KOMENIUSZ Temat: PROCEDURY Z PARAMETRAMI W LOGO KOMENIUSZ."— Zapis prezentacji:

1 LOGO KOMENIUSZ Temat: PROCEDURY Z PARAMETRAMI W LOGO KOMENIUSZ

2 SKŁADNIA OTO NAZWA POLECENIEPOLECENIEPOLECENIEJUŻ PODCZAS TWORZENIA PROCEDURY ZNAK ? ZMIENIA SIĘ NA >

3

4 ! OPTYMALIZACJA

5 ZADANIE ZDEFINIUJ PROCEDURĘ RYSUJĄCĄ CIEŃKI KWADRAT O BOKU 100, CZARNYM KOLORZE

6 OTO KWADRAT UKP 0 UGP 1 POWTÓRZ 4 [NP 100 PW 90] JUŻ Jak przerobić procedurę na taką, która daje możliwość narysowania kwadratu o dowolnie wybranym przez użytkownika boku?

7 PROCEDURE MOŻEMY POPRAWIĆ UŻYWAJĄC PODGLĄDU PAMIĘCI (F4)

8 OTO KWADRAT UKP 0 UGP 1 POWTÓRZ 4 [NP 100 PW 90] JUŻ OTO KWADRAT :BOK UKP 0 UGP 1 POWTÓRZ 4 [NP :BOK PW 90] JUŻ

9 UŻYLIŚMY ZMIENNEJ :BOK (PODOBNIE JAK W ELI – PUDEŁKO, KOSZ NA ŚMIECI, MIEJSCE DO PAMIĘTANIA)

10 WYWOŁANIE POLECENIA

11 ZADANIE: NAPISZ WŁASNE POLECENIE (PROCEDURĘ) RYSUJĄCĄ DOWOLNY WIELOKĄT FOREMNY O WYBRANYM PRZEZ UŻYTKOWNIKA BOKU

12 CZY DA SIĘ NAPISAĆ JEDNĄ PROCEDURĘ NA RYSOWANIE FOREMNEGO TRÓJKĄTA, KWADRATU, PIĘCIOKĄTA, ITD.? CZY DA SIĘ NAPISAĆ JEDNĄ PROCEDURĘ NA RYSOWANIE FOREMNEGO TRÓJKĄTA, KWADRATU, PIĘCIOKĄTA, ITD.? BŁĄD

13

14 OPRACUJ PROCEDURY RYSUJĄCE: SZEŚCIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) SZEŚCIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) OTO SZESC :BOK :KOLOR UKP :KOLOR POWTÓRZ 6 [NP :BOK PW 60] JUŻSpr. szesc (duży granatowy) szesc (mały żółty)

15 ZADANIA OCENIANE OPRACUJ PROCEDURY RYSUJĄCE: KWADRAT O ZADANEJ DŁ. BOKU KWADRAT O ZADANEJ DŁ. BOKU SZEŚCIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) SZEŚCIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) * WIELOKĄT O BOKU 50, PODANEJ ILOŚCI KĄTÓW, KOLORZE I GRUBOŚCI (3 PARAMETRY) * WIELOKĄT O BOKU 50, PODANEJ ILOŚCI KĄTÓW, KOLORZE I GRUBOŚCI (3 PARAMETRY)

16 OPRACUJ PROCEDURY RYSUJĄCE: (3) KWADRAT O ZADANEJ DŁ. BOKU (3) KWADRAT O ZADANEJ DŁ. BOKU (4) OKRĄG O WYBIERANYM KOLORZE (4) OKRĄG O WYBIERANYM KOLORZE (5) OŚMIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) (5) OŚMIOKĄT O ZADANYM BOKU I PODANYM KOLORZE (2 PARAMETRY) (6) (6)

17 (6) Oto spiralka powtórz 1000 [np numpow/300 pw 3] już


Pobierz ppt "LOGO KOMENIUSZ Temat: PROCEDURY Z PARAMETRAMI W LOGO KOMENIUSZ."

Podobne prezentacje


Reklamy Google