Pobieranie prezentacji. Proszę czekać

Pobieranie prezentacji. Proszę czekać

Środowisko Logo Komeniusz Program Logo Komeniusz jest edukacyjnym językiem programowania pracującego w środowisku Windows. Umożliwia rozwiązywanie problemów.

Podobne prezentacje


Prezentacja na temat: "Środowisko Logo Komeniusz Program Logo Komeniusz jest edukacyjnym językiem programowania pracującego w środowisku Windows. Umożliwia rozwiązywanie problemów."— Zapis prezentacji:

1 Środowisko Logo Komeniusz Program Logo Komeniusz jest edukacyjnym językiem programowania pracującego w środowisku Windows. Umożliwia rozwiązywanie problemów oraz uczy zasad poprawnego programowania strukturalnego. Programowanie strukturalne polega na rozkładaniu trudnych problemów na mniejsze w celu ich łatwiejszego zrozumienia i rozwiązania. Program służy do tworzenia rysunków, pisania tekstów, wykonywania obliczeń. Grafika żółwia to technika programowania rysunków w Logo. Procedura jest zapisem algorytmu w postaci instrukcji (poleceń) w danym języku programowania. Procedury pierwotne w Logo służą do rozwiązywania najprostszych problemów, których rozwiązania są znane żółwiowi.

2 Pasek tytułu Pasek menu Paski skrótów Ekran tekstowy żółw Ekran graficzny Wiersz poleceń

3 PROCEDURY PIERWOTNE Polecenie do wykonaniaZnaczenie polecenia pżpokaż żółwia sżschowaj żółwia czyść lub cs czyści ekran i ustawia żółwia na środku zmaż wymazuje wszystko z ekranu, żółw pozostaje na swoim miejscu ścieranie lub ścier opuszczanie gumki do ścierania wróć ustawienie żółwia na środku ekranu naprzód liczba_kroków lub np liczba_kroków przesuń się do przodu o określoną liczbę kroków wstecz liczba_kroków lub ws liczba_kroków cofnij się o określona liczbę kroków prawo kąt lub pw kąt obrót w prawo o określony kąt mierzony w stopniach lewo kąt lub lw kąt obrót w lewo o określony kąt mierzony w stopniach podnieś lub pod podniesienie pisaka – żółw nie pozostawia śladu opuść lub opu opuszczenie pisaka – żółw zostawia ślad

4 Możliwości pisaka Ustalkolorpisaka lub ukp 0-15, jld dowolny kolor Ustalgrubośćpisaka lub ugp Ustalkolormalowania lub ukm Ustaltło Ustal wzórmalowania lub uwm zamaluj

5 Wpisz w wierszu poleceń np 200Enter np 100 lw 90 np 100 lw 90 np 100 lw 90 np 100 wpisz polecenia na rysowanie prostokąta Lina przerywana np 40 pod np 20 opu np 40 pod np 20 opu np 40 powtórz 3 [np 40 pod np 20 opu] Trójkąt prostokątny powtórz 2 [np 100 pw 90] pw 45 np 100 * pwk 2 pod np 100 Prostokąt powtórz 2 [np 100 pw 90 np 60 pw 90] ukp "zielony ugp 4 np 100 ukp "żółty powtórz 6 [np 100 pw 60] ukm [ ] powtórz 5 [np 150 pw 144] ustalkoltła "żółty ukm [ ] zamaluj powtórz 5 [np 150 pw 144] ukm "fioletowy powtórz 24 [np 200 pw 165]

6 Zapisywanie plików zobacz menu plik lub F2, w programie zapis 8 znaków bez spacji, przed umieść znak „Dom. Znak cudzysłowu stosuje się przed słowami, którymi są w logo: litery, cyfry, znaki specjalne oraz znaki przestankowe, nie stosuje się przed liczbami. Standardowo plik jest zapisywany w katalogu comlogo, w podkatalogu projekt. Program dodaje rozszerzenie.lpg. W wersji demo nie jest możliwe zapisywanie.


Pobierz ppt "Środowisko Logo Komeniusz Program Logo Komeniusz jest edukacyjnym językiem programowania pracującego w środowisku Windows. Umożliwia rozwiązywanie problemów."

Podobne prezentacje


Reklamy Google